Thursday, December 8, 2011

My "mad networking skills" saved the day. You might need yours, too, so be prepared.

Thanks to my "mad networking skills" I was able to avoid a cable internet connection disaster this morning.

Last Thursday I jumped at the chance to upgrade my internet connection from 15mbps to 50mbps.  Friday  the new cable modem was installed.  Saturday morning I realized it was acting as a router and had totally disabled my ability to run my site, receive email or replicate databases because my actual router (a SonicWall TZ 210 which I love by the way) needed the public IP address provided not the private address it now received from the cable modem/router.

Saturday morning the support person informed me they could not help and needed to schedule a support visit...on Thursday.  After releasing a little hot steam on the support guy, I spent the rest of the morning switching the required Internet site documents, location documents, connection documents, public and private DNS entries, firewall settings, IP addresses and databases to a publicly accessible server.

This morning arrives, the support guy shows up, doesn't think disabling the private IP address is possible, calls another support guy, spends ten minutes on the phone with him and proceeds to tell me that in order to have my router receive a public IP address (like it did before last Friday) he would have to downgrade the modem back to the previous version which would mean I could not have the new 50mbps connection.

I don't need to tell anyone who may read this that downgrading your connection from 50mbps to 15mbps is absolutely unacceptable so...I let off a little more steam...with the appropriate disclaimers because it was not really this guys' fault.

Off he goes to get a replacement modem from the truck.

He came back in and I said, "Hey, since you are taking this router from me I think it is OK if I get in here and play with some settings..."  After 60 seconds I had found the LAN configuration page, updated the settings to disable DHCP and run the router in bridge mode instead of any version of NAT and poof! we had public IP address tone.  He suggested we test that with my router (we were using a single machine because that is really all the cable companies are wiling to provide support for) which we did and bam! we had public IP address tone on Ye Olde SonicWall and life seemed good again.

I asked him if those settings would be changed through any kind of automated process and he told me that firmware updates were typically checked each night but that unless I asked someone to do it, the actual settings should not be changed.

I do not know which was sweeter:  The fact that it appeared I got to keep my 50mbps connection or the fact that he asked me to show him what I did so he knew how to fix it the next time.

So...moral of the today's story?  If your cable modem is replaced and you rely on your own router getting a public IP address, do a lot more testing before the cable guy leaves and don't be afraid to ask for the credentials to get into the cable modem router so you can use some of your own "mad networking skills"!